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This manual is the technical manual of LNX-900M LED controller, applicable to LNX-900M series

sub-models, the software version is V2.01 and above compatible software version.

LNX-900M sub-models are shown in the table below.

Type Sub-type Software Version | Hardware Version

LNX-900M LNX-900M V2.01 V201

This manual was written and published by LINETX Technology Co., Ltd., and has the final right to
interpret related products.

The follow-up upgrade of related products may be slightly different from this manual, and the
upgrade of the manual may not inform you in time. Please pay attention to the discrepancies between

the actual product and the description in this manual.

For more product information, please visit:  www.linetx.com

Technical Email:: tech@linetx.com
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1. Introduction

1.1. Overview

LNX-900M LED master controller has rich feature which integrated with high-speed INTEL CPU, 2
Gigabit Ethernet ports, SSD and USB, etc. The monitor, mouse and keyboard can be connected to
operate, And it also support using remote desktop to access it at remote PC.

With high-speed Gigabit Ethernet, the LNX-900M can record ARTNET data quickly and store to file,
then play it later. The recorded files are also compatible with other types of LINETX controller, and
can be copied to SD card for playback. Those recorded files can also be edited by using LINETX
LnxEffect LED software to set the frame in/out point of the LED effect.

LNX-900M has the feather that sync the music timeline and LED effect. Edit the timeline, create
empty time slices to timeline, drag the effect file to the time slice, then the effect file and timeline is
linked together to synchronous play. Meanwhile the controller will output the played music through
a 3.5mm audio jack, which can be connected to an audio power amplifier or speaker.

LNX-900M support to receiving ArtNet time code from external devices to synchronize the
playback of local effect files, or sending time code to external devices when playing music.

LNX-900M can scheduled to play LED effect file (recorded or generated by LnxLight), and each
effect file can be assigned some flags, including whether looped play, looped time, and the time to
play.

LNX-900M support ARTNET control, UDP control, and LINETX Cloud control.
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1.2. Application
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1.3. Features

LNX-900M has many functions and features:

» ArtNet: SupportArtNet-4;

» Record and Playback: 2 Giga-Ethernet to recording ArtNet data

> Editable Recorded File: Use LINETX LnxEffect software to edit the recorded file

> Syncwith Music: Edit music timeline to sync playing of the LED effect file

> Edit Timeline: Fasttodrag, scale and delete the time slice in timeline

> Receive Timecode: Receive external timecode to sync the playing of LED effect file
» Send Timecode: Send the timecode while play the media to sync external device
> Scheduled Play: Specify the date and time to play the effect file

» Cycled Play: Support cycled play and can specify the cycle time

» Audio Output: The audio can be playback and output to external speaker

> Black Field: Supportblack filed when device isidle

> FadelIn/Out: Supportfadein /out the effect when playing file is changed

> ArtNet Control: Support to use ArtNet universe channel to control the device

» Cloud Control: Support to use LINETX cloud to control device remotely

> UDP Control: Support to use UDP to control controller by host device;

» Duallanguage: SupportChinese and English

> HMIInterface: Support external monitor and mouse/key to operate

> Remote Desktop: Support access device using remote desktop
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2. Interface of LNX-900M

2.1. Interfaces

° o ¢ o )
Power ON USB USB  UART2 UART1
30 20

Audlo  2*LAN HDMI VGA Power Supply
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3. Configuration

3.1. HMI Of LNX-900M

LNX-900M has HDMI and USB port and can be used for connecting to the mouse, keyboard and
monitor.

And in another way, remote desktop is supported to access the controller too.

3.1.1. Monitor Interface

LNX-900M has both HDMI and VGA interface, those two type of interface is used to connect monitor

according to the type of monitor.

3.1.2. Mouse and Keyboard

LNX-900M has two USB3.0 interface and two USB2.0 interface, those USB ports can be used for

connecting the mouse and keyboard.

3.1.3. Remote Desktop Interface

If it is not suitable for using monitor mouse and keyboard at project, Can use PC to access device
by using remote desktop. When the configuration operation is completed, the remote PC can be
removed, and the controller will operate normally as be configured.

The password of LNX-900M remote desktop is “linetx2020”, Enter the IP, Hostname and password

in the remote desktop dialog, then will success to access the desktop of LNX-900M
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3.2. Configure LED Lighting Show

LNX-900M use LED show project to manage the LED lighting. LED show project contain several
lighting shows, and cue file (effect file generated by LnxEffect or recorded effect file) can be added to the

show. Double-click the show in the list to load the show; after loading the show, double-click the cue

file in the Cuefile list to play ito

3.2.1. Create LED Show

As showed below, click the [File]->[Create Light Show], then a new project will be created:

@ LnxPlayer - unamed.Inxshows

X RE A WA Es XT

|| BERTEETRE Ctrl+N o o
7 ISR Ctrl+0

B #EzisTe Ctrl+S

3
1
1
1
3
1
1
3

Ff [E12% g x

WWW_LINETX.COM|

3.2.2. Add LED Show to Project

Left mouse button to select the show, right click and select [Add a light show] in the pop-up menu

to add a new light show to the project. Click [Clear light show project] to clear all the shows in list.
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@ LnxPlayer - unamed.Inxshows
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3.2.3. Properties of the LED Show

In the show list, right click the mouse button, and the configuration menu will pop up. In this menu,

rename or delete the show or do other configuration, as shown below:

@ LnxPlayer - unamed.Inxshows
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The configuration items of this menu are shown in the following table:

Table 3-1 Configuration items

ID Item Description

1 Rename Change the name of the light show.

2 MRz IT TS Delete this shows

3 AII— NEASCHERNTHTS Add an audio file to the show. After this, the audio can be
used to synchronize to playing of effect file.

4 REAT NSRS Play the audio file linked to the show and generate the local
time code.

5 = IERBIRIA Stop playing the audio linked to the show

6 BCEZATNT Configure the properties of the light show, please refer to
chapter 3.2.4 for detail

3.2.4. Configure LED Show

Click the [Configure this light show] menu of the light show, the dialog show as follows:

BLSRIEE

NewShow

EINE{ES | P /Cloudiusic/NANASE — DEAR™. mp3

NEEAT A TSR AR {3 50 1
HEEE R (F B UT A 5T [E]2 -
FTH S A E: [0:05:00:000 3]

Cancel
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Table 3-2 Configure light show

ID Item Description
1 TS AT Show the path of the audio file linked to LED show
2 DOENT A FSRI B U A 1 When double-click the LED show, the show will be loaded.
Enable to play the linked audio file while loading the light
show
3 PR AT AT BT B4 Link the show to the timeline of audio, Only enable this

there could edit the time slice in the timeline.

4 JTF BT a K E Specify the duration of timeline

3.2.5. Load LED Show

After loaded the LED show, click [Add CUE file to list] in the Cue list, and in the dialog, add multiple

Cue files to the light show, showed as below:

@ LnxPlayer - C:/Users/liufe/Documents/example.Inxshows
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There can delete, clear, move up, move down, and configure the Cue file. Hover the button using

mouse pointer to get the operate tips.

3.2.6. Configure Cue File

In the cue file list, click the [Configure the Cue File], and a dialog will pop up, as shown below:

FR=ECueSiiF
B 1t
A O
EF B |0 g
At [
THRIET[E:  Menday ™ |8:00:00 E“
.

In this dialog, you can configure various attributes of the cue file, as shown in the following table:

Table 3-3 Configure Cue file

ID Item Description

1 T EIRER When loop playback is turned on, the Cue file will restart
while reach the end.

2 BB RUREL When the [Enable Loop Play] option is checked, this can set
the number of looped play times, 0 means infinite loop,
when reached the loop playback times, the next cue file will
be automatically active to play.

3 FFRIH R Enable the scheduled playback, Play the effect file
according to the scheduled time.

4 TR 8] Configure the time of the scheduled play.

3.2.7. Save the LED Show Project

When the light show project is created and well configured, please click [File] -> [Save Light Show
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Project] in the main menu to save the project to file , t can configured to automatically load the project

while power on.

3.3. Options

Click the main menu [Settings] -> [System Options], the options dialog is showed as below:

) LnxPlayer B S%m

v
RS LA .
s

1BHOETR

L= |
I

K35 B = |C:lUsers}Iiufe/Documents
EaEHER s
SR F—NTS: [
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EWEE: |65 g
AR [
=7

IECueRtR AR tH: EINC R

ISR
ArtNetiz#l: Inputzsiaiti:
EBEE: | BE—en |
UDP#s:

| 0K || Cancel |

Configurable item as shown in the following table:

Table3-3  Option Item

ID Item Description
1 B4R 0 Config the network interface
2 BE B Config to use broadcast or unicast to send ArtNode data
3 ITHBXHBR Specify a directory that contains lighting show project.
Then the project can be automatically opened and loaded
when device power on.
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4 BEBHERITATS Config whether automatically start playing the light show
project when starting up.

5 B F—MINFE Config whether automatically load next show to play after
the previous show is finished.

6 FEMFPS Specify the play FPS

7 EH=RE Specify the play brightness

8 KIXE Specify whether use ArtSync

9 E17 Send black data when deviceis idle

10 TR Cue BEENHEH Fade in and fade out the effects when change the CUE files

11 ArtNet #%5 Specify whether to open ArtNet control

12 Input ZS[a)E Specify the Universe address used by ArtNet control

13 RBERE Specify whether to enable the LINETX cloud control

14 UDP $=f1 Specify whether to enable UDP control function

3.4. Configure Timecode

LNX-900M supports the function of receiving and sending time code, use time code to synchronize
the playback of effect Cue files.
In the main menu, click the [Settings] -> [Set Time Code] menu, and the time code dialog will pop

up as follows:.:

Rf I E el

FErfEE:

B Al : [Local Media -

HiEartNeth ] B§5:

Cancel

7 3-4 BYElpE ISk B

‘ ID | Item | Description
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Enable Timecode Click to enable the timecode

2 TImeode source You can choose the local media time code (that is, the local
audio media file linked to the light show), ArtNet external
time code, or system time code. When there is a third-party
audio playback device, and it has the function of sending
ArtNet time code, you can choose ArtNet time code
reception to synchronize the playback of local lighting
effect Cuefiles.

3 Send ArtNet timecode Click to select whether to send out the time code of the
media when playing local media.

3.5. Music and lighting synchronization configuration

Using LNX-900M's music and lighting synchronization function, you can achieve the effect of playing
a specific Cue lighting effect file synchronously at the time node of the music. By accurately grasping the
rhythm of the music, adding the corresponding time slice, the lighting and music form an overall effect

to show An audiovisual effect and feeling with sensory levels and integration.

3.5.1. Show timeline editing window

Click [View] -> [Show/Hide Timeline] in the window menu to switch between displaying or hiding

the timeline window. When you need to edit the timeline, you must first display the timeline window.ss

3.5.2. Timeline editing

To edit the audio timeline, please open it as follows:

a. Referto section 3.4.1to display the timeline editing window;,
b. Refer to section 3.3 to enable local media timecode
c. Referto section 3.2.3 to add a media file to the light show in the light show project and set the timeline length

d. Referto section 3.2.5 Double-click to load the light show
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After these steps, you can add a time slice to the timeline window, as shown in the figure below:

@ LnxPlayer - C:/Users/liufe/Documents/example.Inxshows

M RE E8 WA Es XT

B %=02 00

TR &8 X s

e BF A BE D DD DD DDD
[
2 2rec 52.02 KB C:/Users/liufe/Docume
3 3rec 169.95 KB C:/Users/liufe/Docume

nE omE o B
< IFeTaTo
ollellalle[olw] T O G

A [B]4% g X

WWW LINETX COM|

In the timeline editing window, scroll the wheel to zoom in or zoom out the scale value of the

timeline, and press the right button to drag the timeline left and right.

3.5.3. Add time slice

In order to synchronize the time audio with the light, you need to add a time slice to the audio
timeline. Each time slice can be assigned a light Cue file. When the media playback time reaches the

corresponding time slice, the playback of the Cue file is started. Achieve the effect of audio-visual

synchronization,

Clickthe right mouse button in the timeline window, and the operation menu will pop up as follows:
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@ LnxPlayer - C:/Users/liufe/Documents/example.Inxshows
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3-5 W AERERE

ID Item Description
1 Add a key Cue time slice to Click to add a time slice of the current time, see the third
item for the length of the time slice.
the light show When the music is playing, you can press the shortcut key
Ctrl+K to quickly add time slices, so that you can quickly
add time slices at the required rhythm.
2 Clear all time slices of the | Delete all time slices of this timeline track
time track
3 Set the default time slice | That is, the default time slice length when adding a time
length slice, the length of the time slice can be adjusted by
dragging the two ends of the time slice when needed.
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Move the mouse to the corresponding time slice, click the right mouse button, and click the pop-
up menu [Delete this time slice] to delete the corresponding time slice. Long press the time slice and
drag left and right to quickly adjust the time slice in the time track. Position; move the device to both
sides of the time slice, when the mouse pointer becomes a stretched pointer, long press and drag to

adjust the time length of the time slice.

3.5.4. Specify Cue file for time slice

When a blank time slice is created, its color is gray, which means that the time slice does not specify
any CUE file. Only by assigning a time slice to a CUE file can the playback of the CUE file be triggered in
the time represented by the time slice.

You can quickly drag a CUE file to the time slice with the mouse to complete the specified action of

the CUE file in the time slice, as shown in the figure below
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3.5.5. Play and adjust audio

When the CUE file of the time slice is specified, you can double-click the light show to play the audio
and light effect files simultaneously. Click the left mouse button on the scale part of the time track to
quickly adjust the audio playback time. If [Send ArtNet Time Code] is turned on, the ArtNet time code
will also be sent out synchronously at this time for external device action synchronization
3.6. Output device

Click [Settings] -> [Output Devices] in the main window to view the current remote LED sub-
controller output light control devices. Please note that LNX-900M only supports various types of LED
sub-control devices of the Lingen series.

In the output device window, the searched device name, IP address, port address, MAC address and

other information will be displayed, as shown below:

& BHIgE
wEE PitElE  EHRO MACHEHE ~
1 LNX-378SD1.Nodel 192.168.1.21 0 00-12-20-07-04-08
2 LNX-378SD1.Node2 192.168.1.21 1 00-12-20-07-04-08
3 LNX-378SD1.Node3 192.168.1.21 2 00-12-20-07-04-08
4 LNX-378SD1.Node4 192.168.1.21 3 00-12-20-07-04-08
5 LNX-378SD1.Node5 192.168.1.21 4 00-12-20-07-04-08
6 LNX-378SD1.Node6 192.168.1.21 5 00-12-20-07-04-08
7 LNX-378SD1.Node7 192.168.1.21 6 00-12-20-07-04-08 o
Cancel

3.7. remote control

LNX-900M supports three external control interfaces, including ArtNet control, Lingen cloud control,

UDP control, etc.
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In ArtNet control mode, LNX-900M will become an ArtNet Node device, which can control the device
by using an ArtNet spatial data

In the Lingen cloud control mode, the LNX-900M can be connected to the Lingen cloud control
platform via the Internet, and the device can be remotely controlled from any place with a network
through the Lingen APP on the mobile terminal

In UDP control mode, LNX-900M receives and processes network UDP data packets, and manages

and controls the device by parsing UDP data packets
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